ExternalCommandsData Class

Base class used to contain external command information necessary to construct PushButtonData and MenuItem.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIExternalCommandsData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalCommandsData : IDisposable

The ExternalCommandsData type exposes the following members.

Properties
 NameDescription
Public propertyAssemblyName The assembly path of the menu item.
Public propertyAvailabilityClassName The full class name for the class providing the entry point to decide availability of this menu item.
Public propertyClassName The name of the class containing the implementation for the command.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ExternalCommandsData
Top
See Also