ElementDesignOptionFilter(ElementId) Constructor

Constructs a new instance of a filter to match elements contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementDesignOptionFilter(
	ElementId designOptionId
)

Parameters

designOptionId  ElementId
The design option id to match.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also