CompoundStructureAddWallSweep Method

Adds a new wall sweep or reveal to the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddWallSweep(
	WallSweepInfo wallSweepInfo
)

Parameters

wallSweepInfo  WallSweepInfo
The wall sweep info to create a wall sweep.
Exceptions
ExceptionCondition
ArgumentException The wall sweep info does not represent a fixed wall sweep. Only fixed wall sweeps may be assigned to vertical compound structures. -or- The WallSweepInfo has an invalid id for a fixed wall sweep.
ArgumentNullException A non-optional argument was null
InvalidOperationException This operation is valid only for vertically compound structures.
Remarks

A wall sweep is an object that is created by sweeping a closed 2d profile along a horizontal line that is positioned on one side (exterior or interior) of the hosting wall. A reveal is a special wall sweep with a void shape that is subtracted from the hosting wall.

The id field of the WallSweepInfo must be populated with a non-negative integer value. If there already is a sweep defined for this id, its parameters will be changed. A new sweep will be created if no existing one has matching id.

See Also