DocumentNewFlexDuct(Connector, IListXYZ, FlexDuctType) Method |
Adds a new flexible duct into the document,
using a connector, point array and duct type.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FlexDuct NewFlexDuct(
Connector connector,
IList<XYZ> points,
FlexDuctType ductType
)
Public Function NewFlexDuct (
connector As Connector,
points As IList(Of XYZ),
ductType As FlexDuctType
) As FlexDuct
public:
FlexDuct^ NewFlexDuct(
Connector^ connector,
IList<XYZ^>^ points,
FlexDuctType^ ductType
)
member NewFlexDuct :
connector : Connector *
points : IList<XYZ> *
ductType : FlexDuctType -> FlexDuct
Parameters
- connector Connector
- The connector to be connected to the duct, including the end points.
- points IListXYZ
- The point array indicating the path of the flexible duct.
- ductType FlexDuctType
- The type of the flexible duct.
Return Value
FlexDuct If creation was successful then a new flexible duct is returned,
otherwise an exception with failure information will be thrown.
Exceptions
RemarksIf the connector is a fitting or equipment connector of the correct domain,
and if the connector's direction matches the direction of the flexible duct to be created,
the connectors will be automatically connected. A transition fitting will be added
at the connector(s) if necessary. If the connector's type, domain,
does not match the one of the input connector, no connection will be established.
See Also