RailingIsValidPathForRailing Method |
Checks whether a railing can be created along a railing path.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidPathForRailing(
CurveLoop curveLoop
)
Public Shared Function IsValidPathForRailing (
curveLoop As CurveLoop
) As Boolean
public:
static bool IsValidPathForRailing(
CurveLoop^ curveLoop
)
static member IsValidPathForRailing :
curveLoop : CurveLoop -> bool
Parameters
- curveLoop CurveLoop
-
The railing path along which the new railing will be created.
Return Value
Boolean
True if the new railing path can be used in a railing definition, False otherwise.
Exceptions
Remarks
The railing path should be located on the same horizontal plane and it should contain lines or arcs only.
It also has to be continuous and its three or more curves cannot meet in one end point.
See Also