AnalyticalOpeningCreate Method

Creates a new instance of an Analytical Opening within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static AnalyticalOpening Create(
	Document aDoc,
	CurveLoop curveLoop,
	ElementId panelId
)

Parameters

aDoc  Document
Revit document.
curveLoop  CurveLoop
CurveLoop for the Analytical Opening.
panelId  ElementId
ElementId of the AnalyticalPanel on which we create the Opening.

Return Value

AnalyticalOpening
The newly created AnalyticalOpening instance.
Exceptions
ExceptionCondition
ArgumentException One of the following requirements is not satisfied : - curve loop curveLoop is not planar - curve loop curveLoop is self-intersecting - curve loop curveLoop contains zero length curves - curve loop curveLoop is not inside or does not intersect the AnalyticalPanel on which we want to create the Opening. - panelId is not the ElementId of an AnalyticalPanel - curve loop curveLoop is not in the same plane as the Analytical Panel
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
CurveLoop must be planar, not self-intersecting and in the same plane as the Analytical Panel. CurveLoop must intersect or to be inside the AnalyticalPanel contour. PanelId must be the ElementId of an AnalyticalPanel otherwise an exception is thrown.
See Also