CurveByPointsSortPoints Method |
Order a set of ReferencePoints in the same way Revit does
when creating a curve from points.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool SortPoints(
ReferencePointArray arr
)
Public Shared Function SortPoints (
arr As ReferencePointArray
) As Boolean
public:
static bool SortPoints(
ReferencePointArray^ arr
)
static member SortPoints :
arr : ReferencePointArray -> bool
Parameters
- arr ReferencePointArray
- An array of ReferencePoints. The array is reordered
if sortPoints returns true, and is unchanged if
sortPoints returns false.
Return Value
BooleanFalse if the least-squares method is unable to find a solution;
true otherwise.
RemarksFinds a best-fit line to the points by the least squares method,
and orders the points by their projection onto the line.
See Also