ViewShapeBuilderValidateCurve(Curve, DirectShapeTargetViewType) Method |
Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input.
This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool ValidateCurve(
Curve GCurve,
DirectShapeTargetViewType targetViewType
)
Public Shared Function ValidateCurve (
GCurve As Curve,
targetViewType As DirectShapeTargetViewType
) As Boolean
public:
static bool ValidateCurve(
Curve^ GCurve,
DirectShapeTargetViewType targetViewType
)
static member ValidateCurve :
GCurve : Curve *
targetViewType : DirectShapeTargetViewType -> bool
Parameters
- GCurve Curve
-
Curve object to be validated.
- targetViewType DirectShapeTargetViewType
-
View type for which this curve is intended.
Return Value
Boolean
True is %GCurve% is acceptable as a part of view-specific shape representation.
Exceptions
Remarks
Validation conditions depend on the type of view for which the shape representation is intended.
For plan views, a curve is expected to be planar and non-degenerate (e.g., NOT a circle of zero radius).
See Also