InsulationLiningBaseGetInsulationIds Method

Returns the ids of the insulation elements associated to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> GetInsulationIds(
	Document document,
	ElementId elemId
)

Parameters

document  Document
The document.
elemId  ElementId
The element.

Return Value

ICollectionElementId
A collection of the ids of the insulation elements.
Exceptions
ExceptionCondition
ArgumentException This id does not represent a valid host for insulation.
ArgumentNullException A non-optional argument was null
See Also