ExporterIFCUtilsCollectGeometryInfo(ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean) Method |
Collects all the target geometry from the input geometry object and adds it as IFC handles
to the IFCInfo.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void CollectGeometryInfo(
ExporterIFC exporterIFC,
IFCGeometryInfo geometryInfo,
GeometryObject gNode,
XYZ offset,
bool forceVisible
)
Public Shared Sub CollectGeometryInfo (
exporterIFC As ExporterIFC,
geometryInfo As IFCGeometryInfo,
gNode As GeometryObject,
offset As XYZ,
forceVisible As Boolean
)
public:
static void CollectGeometryInfo(
ExporterIFC^ exporterIFC,
IFCGeometryInfo^ geometryInfo,
GeometryObject^ gNode,
XYZ^ offset,
bool forceVisible
)
static member CollectGeometryInfo :
exporterIFC : ExporterIFC *
geometryInfo : IFCGeometryInfo *
gNode : GeometryObject *
offset : XYZ *
forceVisible : bool -> unit
Parameters
- exporterIFC ExporterIFC
-
The exporter.
- geometryInfo IFCGeometryInfo
-
The container object which collects the geometry.
- gNode GeometryObject
-
The geometry object to be processed.
- offset XYZ
-
The offset to apply to each of the collected geometry handles.
- forceVisible Boolean
-
True to process geometry which is not set as visible. False to only process visible geometry.
Exceptions
Remarks
The type of geometry collected is determined by the method of creation for the IFCGeometryInfo.
See Also