StairsEditScopeStart(ElementId, ElementId) Method |
Creates a new empty stairs element with a default stairs type in the specified levels
and then starts stairs edit mode and editing the new stairs.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId Start(
ElementId baseLevelId,
ElementId topLevelId
)
Public Function Start (
baseLevelId As ElementId,
topLevelId As ElementId
) As ElementId
public:
ElementId^ Start(
ElementId^ baseLevelId,
ElementId^ topLevelId
)
member Start :
baseLevelId : ElementId *
topLevelId : ElementId -> ElementId
Parameters
- baseLevelId ElementId
-
The base level on which the stairs is to be placed.
- topLevelId ElementId
-
The top level where the stairs is to reach.
Return Value
ElementId
ElementId of the new stairs.
ExceptionsException | Condition |
---|
ArgumentException |
It is not a Level's id.
-or-
Top level should be higher than base level.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
This StairsEditScope is not permitted to start at this moment for one of the following possible reasons:
The document is in read-only state, or the document is currently modifiable,
or there already is another edit mode active in the document.
|
Remarks
A new stairs will be created after this operation.
User will need to start a transaction to actually make changes to the stairs element.
StairsEditScope can only be started when there is no transaction active
Thus it does not work for commands running in automatic transaction mode.
See Also