MEPAnalyticalConnectionTypeFindTypeByName Method |
Finds the analytical connection type by its name.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId FindTypeByName(
Document doc,
string name
)
Public Shared Function FindTypeByName (
doc As Document,
name As String
) As ElementId
public:
static ElementId^ FindTypeByName(
Document^ doc,
String^ name
)
static member FindTypeByName :
doc : Document *
name : string -> ElementId
Parameters
- doc Document
-
The document where the analytical conneciton type is expected.
- name String
-
The name of the expected analytical connection type.
Return Value
ElementId
The element id of matched analytical connection type, otherwise invalidElementId.
Exceptions
See Also