ColorSelectionDialog Class

Allows display of the Revit Color dialog.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIColorSelectionDialog

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ColorSelectionDialog : IDisposable

The ColorSelectionDialog type exposes the following members.

Constructors
 NameDescription
Public methodColorSelectionDialog Default constructor.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyOriginalColor The original color.
Public propertySelectedColor The new color selected by the user.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ColorSelectionDialog
Public methodShow Shows the Revit Color dialog as a modal dialog.
Top
Remarks
The class provides the option to launch the Revit Color dialog to select the color.
See Also