ElementLogicalFilter Class

A filter used to logically combine two or more filters.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementLogicalFilter
      Autodesk.Revit.DBLogicalAndFilter
      Autodesk.Revit.DBLogicalOrFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementLogicalFilter : ElementFilter

The ElementLogicalFilter type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodGetFilters Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter.
Public methodSetFilters Replaces current filters in the logical filter with any number of input filters.
Top
Remarks
The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.
See Also