DisplayingOptionsDialogEventArgsAddTab Method |
Add tab to option dialog with tab name and handler information.
Namespace: Autodesk.Revit.UI.EventsAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddTab(
string newTabName,
TabbedDialogExtension tabbedDialogExtension
)
Public Sub AddTab (
newTabName As String,
tabbedDialogExtension As TabbedDialogExtension
)
public:
void AddTab(
String^ newTabName,
TabbedDialogExtension^ tabbedDialogExtension
)
member AddTab :
newTabName : string *
tabbedDialogExtension : TabbedDialogExtension -> unit
Parameters
- newTabName String
- The new tab page name.
- tabbedDialogExtension TabbedDialogExtension
- The handlers information for the new tab page.
ExceptionsException | Condition |
---|
InvalidOperationException | Thrown when the limit
of pages allowed in the Options dialog will be exceeded (99). |
Remarks
There is a limit to the number of options page permitted in the dialog.
See Also