RebarBarTypeGetLapLength Method |
Gets the lap length taking into account the specified Rebar Splice Type.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetLapLength(
ElementId rebarSpliceTypeId
)
Public Function GetLapLength (
rebarSpliceTypeId As ElementId
) As Double
public:
double GetLapLength(
ElementId^ rebarSpliceTypeId
)
member GetLapLength :
rebarSpliceTypeId : ElementId -> float
Parameters
- rebarSpliceTypeId ElementId
-
The Rebar Splice Type id.
Interactions with Rebar Splice Types can be done with the functions in RebarSpliceTypeUtils.
Return Value
Double
Returns the lap length.
ExceptionsException | Condition |
---|
ArgumentException |
The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
|
ArgumentNullException |
A non-optional argument was null
|
See Also