UISaveAsOptions Class

This class contains UI options available for saving a document to disk with a new filename.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIUISaveAsOptions

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class UISaveAsOptions : IDisposable

The UISaveAsOptions type exposes the following members.

Constructors
 NameDescription
Public methodUISaveAsOptions Default constructor.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyShowOverwriteWarning Identifies if UI should show an overwrite warning dialog.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the UISaveAsOptions
Top
See Also