CompoundStructureSetLayer Method

Sets a single layer for this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetLayer(
	int layerIdx,
	CompoundStructureLayer layer
)

Parameters

layerIdx  Int32
The index of a layer. This should range from 0 to the number of layers - 1.
layer  CompoundStructureLayer
The layer to be set.
Exceptions
ExceptionCondition
ArgumentException The layer is not valid for this operation.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The layer index is out of range.
InvalidOperationException This operation is valid only for non-vertically compound structures.
Remarks
This function does not support addition of new layers, use SetLayers() to change the number of layers.
See Also