ElevationMarkerCreateReferenceElevation Method |
Creates a reference elevation on the ElevationMarker at the desired index.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void CreateReferenceElevation(
Document document,
int index,
ElementId viewIdToReference
)
Public Sub CreateReferenceElevation (
document As Document,
index As Integer,
viewIdToReference As ElementId
)
public:
void CreateReferenceElevation(
Document^ document,
int index,
ElementId^ viewIdToReference
)
member CreateReferenceElevation :
document : Document *
index : int *
viewIdToReference : ElementId -> unit
Parameters
- document Document
-
The document to which the new reference elevation will be added.
- index Int32
-
The index on the ElevationMarker where the reference elevation will be placed.
- viewIdToReference ElementId
-
The view which will be referenced.
ExceptionsException | Condition |
---|
ArgumentException |
The ElementId viewIdToReference does not correspond to a View.
-or-
This view cannot be referenced by elevations.
-or-
index is occupied or out of range.
-or-
Elevation view creation is not allowed in this family.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
Only reference elevations can be hosted on this ElevationMarker.
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also