PartMakerMethodToDivideVolumesRemoveIntersectingReference Method |
Removed intersecting reference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool RemoveIntersectingReference(
ElementId intersectingReference
)
Public Function RemoveIntersectingReference (
intersectingReference As ElementId
) As Boolean
public:
bool RemoveIntersectingReference(
ElementId^ intersectingReference
)
member RemoveIntersectingReference :
intersectingReference : ElementId -> bool
Parameters
- intersectingReference ElementId
-
Id of the intersecting reference to remove.
Return Value
Boolean
True if the PartMaker used this intersecting reference and
this call removed it, false if the PartMaker did not use this
intersecting reference.
ExceptionsException | Condition |
---|
ArgumentException |
The element id was not permitted as intersecting references.
Intersecting references should be levels, grids, or reference planes.
|
ArgumentNullException |
A non-optional argument was null
|
See Also