StairsRunGetNumberSystemReference Method |
Gets the number system reference corresponding to the given reference options.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Reference GetNumberSystemReference(
StairsNumberSystemReferenceOption referenceOption
)
Public Function GetNumberSystemReference (
referenceOption As StairsNumberSystemReferenceOption
) As Reference
public:
Reference^ GetNumberSystemReference(
StairsNumberSystemReferenceOption referenceOption
)
member GetNumberSystemReference :
referenceOption : StairsNumberSystemReferenceOption -> Reference
Parameters
- referenceOption StairsNumberSystemReferenceOption
-
The reference option.
Return Value
Reference
The reference.
Exceptions
Remarks
The return value of this function is suitable for use in NumberSystem.Create()
to associate a NumberSystem with the location on the StairsRun.
Don't try to get geometry curve from the reference.
See Also