ZoneEquipmentGetAssociatedZoneEquipment(Document, ElementId) Method |
Gets the associated zone equipment of the specified analytical space.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ISet<ElementId> GetAssociatedZoneEquipment(
Document document,
ElementId spaceElementId
)
Public Shared Function GetAssociatedZoneEquipment (
document As Document,
spaceElementId As ElementId
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ GetAssociatedZoneEquipment(
Document^ document,
ElementId^ spaceElementId
)
static member GetAssociatedZoneEquipment :
document : Document *
spaceElementId : ElementId -> ISet<ElementId>
Parameters
- document Document
-
The document where the analytical spaces and zone equipment exist.
- spaceElementId ElementId
-
The specified analytical spaces.
Return Value
ISetElementId
All associated zone equipment, either explicitly assigned or implicitly assigned via system-zone.
Exceptions
See Also