ConceptualConstructionTypeGetShadeConstructionType Method |
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId GetShadeConstructionType(
Document ccda,
ConceptualConstructionShadeType typeEnum
)
Public Shared Function GetShadeConstructionType (
ccda As Document,
typeEnum As ConceptualConstructionShadeType
) As ElementId
public:
static ElementId^ GetShadeConstructionType(
Document^ ccda,
ConceptualConstructionShadeType typeEnum
)
static member GetShadeConstructionType :
ccda : Document *
typeEnum : ConceptualConstructionShadeType -> ElementId
Parameters
- ccda Document
-
The Document.
- typeEnum ConceptualConstructionShadeType
-
The ConceptualConstructionShadeType to get the ConceptualConstructionType for.
Return Value
ElementId
Returns ElementId of a ConceptualConstructionType.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
The enum is invalid for ConceptualConstructionShadeType.
-or-
A value passed for an enumeration argument is not a member of that enumeration
|
See Also