EffectInstance Constructor |
Constructs the effect instance for geometry having the specified vertex format.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic EffectInstance(
VertexFormatBits vertexFormatBits
)
Public Sub New (
vertexFormatBits As VertexFormatBits
)
public:
EffectInstance(
VertexFormatBits vertexFormatBits
)
new :
vertexFormatBits : VertexFormatBits -> EffectInstance
Parameters
- vertexFormatBits VertexFormatBits
-
The vertex format of the geometry to be used with this effect instance.
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
This EffectInstance is not available because Revit is not currently rendering. In general, this EffectInstance must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
|
See Also