InCanvasControlDataImagePath Property |
The path to the image file to be used.
This must be an absolute path to a location on disk.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string ImagePath { get; set; }
Public Property ImagePath As String
Get
Set
public:
property String^ ImagePath {
String^ get ();
void set (String^ value);
}
member ImagePath : string with get, set
Property Value
String
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The file format specified by imagePath is an unsupported format - only *.bmp files are supported.
-or-
When setting this property: The file path specified by imagePath is not absolute.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
FileArgumentNotFoundException |
When setting this property: The file specified by imagePath doesn't exist.
|
See Also