ReinforcementRoundingManager Class

A base class providing access to reinforcement rounding overrides for structural elements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureReinforcementRoundingManager
    Autodesk.Revit.DB.StructureFabricRoundingManager
    Autodesk.Revit.DB.StructureRebarRoundingManager

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ReinforcementRoundingManager : IDisposable

The ReinforcementRoundingManager type exposes the following members.

Properties
 NameDescription
Public propertyElement The owner of the reinforcement rounding overrides.
Public propertyIsActiveOnElement Defines whether reinforcement rounding is activated for the particular element.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ReinforcementRoundingManager
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetLengthUnitTypeId Gets the identifier of the length unit quantifying the reinforcement rounding values.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Subclasses of this class are used to access the override settings for Rebar elements and types or Fabric elements and types.
See Also