DimensionTypeSetUnitsFormatOptions Method |
Sets the FormatOptions to optionally override the default settings in the Units class for the units value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetUnitsFormatOptions(
FormatOptions formatOptions
)
Public Sub SetUnitsFormatOptions (
formatOptions As FormatOptions
)
public:
void SetUnitsFormatOptions(
FormatOptions^ formatOptions
)
member SetUnitsFormatOptions :
formatOptions : FormatOptions -> unit
Parameters
- formatOptions FormatOptions
-
The FormatOptions.
ExceptionsException | Condition |
---|
ArgumentException |
The display unit in formatOptions is not a valid display unit for the unit type of this DimensionType, or the rounding method in formatOptions is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
See the UnitType property to determine the unit type of this dimension style.
See Also