SpatialFieldManagerUpdateSpatialFieldPrimitive Method |
Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void UpdateSpatialFieldPrimitive(
int idx,
FieldDomainPoints fieldDomainPoints,
FieldValues fieldValues,
int resultIndex
)
Public Sub UpdateSpatialFieldPrimitive (
idx As Integer,
fieldDomainPoints As FieldDomainPoints,
fieldValues As FieldValues,
resultIndex As Integer
)
public:
void UpdateSpatialFieldPrimitive(
int idx,
FieldDomainPoints^ fieldDomainPoints,
FieldValues^ fieldValues,
int resultIndex
)
member UpdateSpatialFieldPrimitive :
idx : int *
fieldDomainPoints : FieldDomainPoints *
fieldValues : FieldValues *
resultIndex : int -> unit
Parameters
- idx Int32
-
Unique index identifying the primitive
- fieldDomainPoints FieldDomainPoints
-
Set of domain points.
If the new set of domain points is supplied, all previously supplied domain points and field values for all results are removed from the primitive.
If %fieldDomainPoints% is only fieldValues are updated
- fieldValues FieldValues
-
Set of data values.
Number of values in fieldValues must coincide with the number of points in fieldDomainPoints
- resultIndex Int32
-
Unique index identifying the result schema
ExceptionsException | Condition |
---|
ArgumentException |
idx refers to non-existent primitive
-or-
fieldValues has incorrect number of measurements in ValueAtPoint objects
-or-
fieldDomainPoints has inconsistent type
-or-
resultIndex refers to non-existent result schema
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentsInconsistentException |
fieldDomainPoints and fieldValues have inconsistent number of points
|
See Also