PointCloudInstanceFilterAction Property |
The action taken based on the results of the selection filter applied to this point cloud.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SelectionFilterAction FilterAction { get; set; }
Public Property FilterAction As SelectionFilterAction
Get
Set
public:
property SelectionFilterAction FilterAction {
SelectionFilterAction get ();
void set (SelectionFilterAction value);
}
member FilterAction : SelectionFilterAction with get, set
Property Value
SelectionFilterAction
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
If no selection filter is applied, changing this value will have no visible effect.
The filter is provided in the coordinates of the Revit model. If the point cloud is
altered (e.g. by moving, rotating, scaling or other modifications) the point cloud
filter is not modified and the set of highlighted or isolated points will change.
The filter action is not preserved when the Revit document is saved.
See Also