FloorTypeStructuralMaterialId Property

Returns the identifier of the material that defines the element's structural analysis properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId StructuralMaterialId { get; set; }

Property Value

ElementId
Exceptions
ExceptionCondition
ArgumentNullException When setting this property: A non-optional argument was null
InvalidOperationException When setting this property: the floor does not have a structural material
See Also