CurveByPointsUtilsValidateCurveElementIdArrayForFaceRegions Method |
Validates that the input CurveElements can define FaceRegions.
The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common
Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition,
a CurveElement must have the SketchOnSurface attribute set.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool ValidateCurveElementIdArrayForFaceRegions(
Document document,
IList<ElementId> curveElemIds
)
Public Shared Function ValidateCurveElementIdArrayForFaceRegions (
document As Document,
curveElemIds As IList(Of ElementId)
) As Boolean
public:
static bool ValidateCurveElementIdArrayForFaceRegions(
Document^ document,
IList<ElementId^>^ curveElemIds
)
static member ValidateCurveElementIdArrayForFaceRegions :
document : Document *
curveElemIds : IList<ElementId> -> bool
Parameters
- document Document
-
The Document.
- curveElemIds IListElementId
-
The CurveElements.
Return Value
Boolean
Exceptions
See Also