TopographySurfaceIsValidFaceSet Method |
Identifies whether the facets can construct a valid topography surface.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidFaceSet(
IList<PolymeshFacet> facets,
IList<XYZ> points
)
Public Shared Function IsValidFaceSet (
facets As IList(Of PolymeshFacet),
points As IList(Of XYZ)
) As Boolean
public:
static bool IsValidFaceSet(
IList<PolymeshFacet^>^ facets,
IList<XYZ^>^ points
)
static member IsValidFaceSet :
facets : IList<PolymeshFacet> *
points : IList<XYZ> -> bool
Parameters
- facets IListPolymeshFacet
-
The facets to be checked.
- points IListXYZ
-
A collection of points.
Return Value
Boolean
True if the facets are valid, otherwise false.
ExceptionsException | Condition |
---|
ArgumentException |
There are no points in the input points set.
-or-
There were not enough points to form a valid region (at least 3 are required), or the points were collinear ignoring elevation.
|
ArgumentNullException |
A non-optional argument was null
|
See Also