SiteSubRegionIsValidBoundary Method |
Identifies whether the given curve loops compose a valid boundary.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidBoundary(
IList<CurveLoop> curveLoops
)
Public Shared Function IsValidBoundary (
curveLoops As IList(Of CurveLoop)
) As Boolean
public:
static bool IsValidBoundary(
IList<CurveLoop^>^ curveLoops
)
static member IsValidBoundary :
curveLoops : IList<CurveLoop> -> bool
Parameters
- curveLoops IListCurveLoop
-
The curve loops to be checked.
Return Value
Boolean
True if the given curve loops don't intersect with each other; each curve loop is closed;
and each loop is planar and lies on a plane parallel to the horizontal(XY) plane.
Any requirement above is not satisfied or no curve loops contained, returns false.
Exceptions
Remarks
The curve loops are valid if they don't intersect with each other; each curve loop is closed;
and each loop is planar and lies on a plane parallel to the horizontal(XY) plane.
See Also