IDuplicateTypeNamesHandler Interface |
An interface for custom handlers of duplicate type names encountered during a paste operation. When the destination document
contains types that have the same names as the types being copied, but different internals, a decision must be made on how to proceed - whether to
cancel the operation or continue, but only copy types with unique names.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic interface IDuplicateTypeNamesHandler
Public Interface IDuplicateTypeNamesHandler
public interface class IDuplicateTypeNamesHandler
type IDuplicateTypeNamesHandler = interface end
The IDuplicateTypeNamesHandler type exposes the following members.
Methods | Name | Description |
---|
 | OnDuplicateTypeNamesFound |
Called when the destination document contains types with the same names as the types being copied.
|
Top
See Also