MassSurfaceDataSurfaceDataSource Property |
Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings
of the Document or are overridden for the surface.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic MassSurfaceDataSource SurfaceDataSource { get; set; }
Public Property SurfaceDataSource As MassSurfaceDataSource
Get
Set
public:
property MassSurfaceDataSource SurfaceDataSource {
MassSurfaceDataSource get ();
void set (MassSurfaceDataSource value);
}
member SurfaceDataSource : MassSurfaceDataSource with get, set
Property Value
MassSurfaceDataSource
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The surface data source does not fall within an appropriate range.
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
The Construction property is not governed by this setting and
has a separate value to indicate if it is to be synchronized
with EnergyDataSettings.
See Also