Creates an object representing element or subelement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Subelement Create(
Document aDoc,
Reference reference
)
Public Shared Function Create (
aDoc As Document,
reference As Reference
) As Subelement
public:
static Subelement^ Create(
Document^ aDoc,
Reference^ reference
)
static member Create :
aDoc : Document *
reference : Reference -> Subelement
Parameters
- aDoc Document
-
The document.
- reference Reference
-
The reference that identifies element or subelement.
Return Value
Subelement
The newly created subelement.
Exceptions
Remarks
If %reference% points to linked document:
- The GetReference method of the newly created subelement will return the local reference in the linked document.
- The Document property of the newly created subelement will return the linked document.
See Also