FormUtilsDissolveForms(Document, ICollectionElementId) Method

Dissolves a collection of form elements into their defining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> DissolveForms(
	Document ADoc,
	ICollection<ElementId> elements
)

Parameters

ADoc  Document
The document
elements  ICollectionElementId
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.

Return Value

ICollectionElementId
A collection of curve element ids from the profiles and paths of the dissolved forms.
Exceptions
ExceptionCondition
ArgumentException The elements do not include Forms that can be dissolved.
ArgumentNullException A non-optional argument was null
See Also