DirectShapeLibraryAddDefinitionType Method |
Add a definition to be reused by instances. Adding a definition type will change how the instances are created.
When asked to create a definition, the library object will look for a corresponding type object.
If one is found, it will create an instance of geometry stored in the type object. If it is not found,
the library will look for a list of geometry objects stored as definition, and will copy and transform these
to create an instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddDefinitionType(
string id,
ElementId typeId
)
Public Sub AddDefinitionType (
id As String,
typeId As ElementId
)
public:
void AddDefinitionType(
String^ id,
ElementId^ typeId
)
member AddDefinitionType :
id : string *
typeId : ElementId -> unit
Parameters
- id String
-
ID of the definition to be added. Must be unique.
- typeId ElementId
-
Element id of the DirectShapeType element that will be used as a definition.
Exceptions
See Also