RevitLinkTypeSavePositions Method |
Saves shared coordinates changes back to the linked document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool SavePositions(
ISaveSharedCoordinatesCallback callback
)
Public Function SavePositions (
callback As ISaveSharedCoordinatesCallback
) As Boolean
public:
bool SavePositions(
ISaveSharedCoordinatesCallback^ callback
)
member SavePositions :
callback : ISaveSharedCoordinatesCallback -> bool
Parameters
- callback ISaveSharedCoordinatesCallback
-
A callback object to resolve situations when Revit encounters
modified links.
Return Value
Boolean
True if we saved the link or if there were no changes to save.
False if the operation failed.
ExceptionsException | Condition |
---|
InvalidOperationException |
Revit could not save shared coordinates changes to the link
or one of its nested links.
|
Remarks
While this operation does not clear the document's undo history,
you will not be able to undo this specific action, since it saves
the link's shared coordinates changes to disk.
See Also