Sets the railing path.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetPath(
CurveLoop curveLoop
)
Public Sub SetPath (
curveLoop As CurveLoop
)
public:
void SetPath(
CurveLoop^ curveLoop
)
member SetPath :
curveLoop : CurveLoop -> unit
Parameters
- curveLoop CurveLoop
-
The railing path along which the new railing will be created.
The curveLoop should be continuous with curves which are only bounded lines and arcs on the same horizontal plane.
It also has to have maximum two curves meet in one end point.
ExceptionsException | Condition |
---|
ArgumentException |
The curveLoop must be a single connected path, located on the same horizontal plane and defined using lines or arcs only.
It also has to have maximum two curves meet in one end point.
|
ArgumentNullException |
A non-optional argument was null
|
InapplicableDataException |
The railing has incorrect internal data.
|
See Also