RebarContainerParameterManagerGetDoubleOverrideValue Method |
Get the double value for an overriden parameter.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetDoubleOverrideValue(
ElementId paramId
)
Public Function GetDoubleOverrideValue (
paramId As ElementId
) As Double
public:
double GetDoubleOverrideValue(
ElementId^ paramId
)
member GetDoubleOverrideValue :
paramId : ElementId -> float
Parameters
- paramId ElementId
-
The id of the parameter
Return Value
Double
The override value of the parameter.
ExceptionsException | Condition |
---|
ArgumentException |
paramId is not the id of a parameter in the current document,
or its value type is not double.
-or-
paramId is not a Rebar Container parameter
-or-
paramId has no override
|
ArgumentNullException |
A non-optional argument was null
|
See Also