ElementDesignOptionFilter(ElementId, Boolean) Constructor |
Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementDesignOptionFilter(
ElementId designOptionId,
bool inverted
)
Public Sub New (
designOptionId As ElementId,
inverted As Boolean
)
public:
ElementDesignOptionFilter(
ElementId^ designOptionId,
bool inverted
)
new :
designOptionId : ElementId *
inverted : bool -> ElementDesignOptionFilter
Parameters
- designOptionId ElementId
-
The design option id to match.
- inverted Boolean
-
True if the filter should match all elements which are not contained within a particular design option.
Exceptions
See Also