StairsTypeNotchExtension Property |
The horizontal length of the notch profile.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double NotchExtension { get; set; }
Public Property NotchExtension As Double
Get
Set
public:
property double NotchExtension {
double get ();
void set (double value);
}
member NotchExtension : float with get, set
Property Value
Double
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: The given value for notchExtension must be no more than 30000 feet in absolute value.
|
InvalidOperationException |
When setting this property: The construction method of the stairs type is not "Precast" or the StairsEndConnectionType of the stairs type is not "Notch", so this related data cannot be set.
|
See Also