ExporterIFCUtilsTransformAndScalePoint Method |
Converts a point from global Revit coordinates to current IFC coordinates, including scale.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static XYZ TransformAndScalePoint(
ExporterIFC exporterIFC,
XYZ origPt
)
Public Shared Function TransformAndScalePoint (
exporterIFC As ExporterIFC,
origPt As XYZ
) As XYZ
public:
static XYZ^ TransformAndScalePoint(
ExporterIFC^ exporterIFC,
XYZ^ origPt
)
static member TransformAndScalePoint :
exporterIFC : ExporterIFC *
origPt : XYZ -> XYZ
Parameters
- exporterIFC ExporterIFC
-
The exporter.
- origPt XYZ
-
The original point.
Return Value
XYZ
The transformed and scaled point.
Exceptions
See Also