ExporterIFCUtilsGetLoopsFromTopBottomFace Method |
Gets the curve loop(s) that represent the bottom or top face of the wall, usable to create an extrusion for the wall geometry.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<CurveLoop> GetLoopsFromTopBottomFace(
ExporterIFC exporterIFC,
Wall wall
)
Public Shared Function GetLoopsFromTopBottomFace (
exporterIFC As ExporterIFC,
wall As Wall
) As IList(Of CurveLoop)
public:
static IList<CurveLoop^>^ GetLoopsFromTopBottomFace(
ExporterIFC^ exporterIFC,
Wall^ wall
)
static member GetLoopsFromTopBottomFace :
exporterIFC : ExporterIFC *
wall : Wall -> IList<CurveLoop>
Parameters
- exporterIFC ExporterIFC
-
The exporter.
- wall Wall
-
The wall.
Return Value
IListCurveLoop
The curve loops. If the function has failed, this collection will be empty.
Exceptions
Remarks
This function is intended to help determine if a Revit Wall can be exported as an IfcWallStandardCase. The conditions for
exporting an IfcWallStandardCase require that the geometry of the wall be described as one profile curve loop extruded in the
Z direction, with potential clip planes and openings applied to the base geometry. This function will use either the top
or bottom face to determine the boundary curve loop. Regardless of whether the top or bottom face is used, the curve loop
will be located on the plane corresponding to the base of the wall.
See Also