SubTransactionStart Method

Starts the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public TransactionStatus Start()

Return Value

TransactionStatus
If started successfully, this method returns TransactionStatus.Started.
Exceptions
ExceptionCondition
InvalidOperationException Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction was already started and has not finished yet.
Remarks

A sub-transaction can only be started in an open transaction, and it must be closed (committed or rolled back) while still inside the open transaction.

A sub-transaction can be started in another open sub-transaction, but then it must be closed before the parent sub-transaction is closed.

See Also