ViewGetCropRegionShapeManagerForReferenceCallout Method |
Returns an object for managing view crop region shape for reference callout.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ViewCropRegionShapeManager GetCropRegionShapeManagerForReferenceCallout(
Document doc,
ElementId callout
)
Public Shared Function GetCropRegionShapeManagerForReferenceCallout (
doc As Document,
callout As ElementId
) As ViewCropRegionShapeManager
public:
static ViewCropRegionShapeManager^ GetCropRegionShapeManagerForReferenceCallout(
Document^ doc,
ElementId^ callout
)
static member GetCropRegionShapeManagerForReferenceCallout :
doc : Document *
callout : ElementId -> ViewCropRegionShapeManager
Parameters
- doc Document
-
Document to which the callout belongs.
- callout ElementId
-
Element id of reference callout.
Return Value
ViewCropRegionShapeManager
The crop region shape manager.
Exceptions
Remarks
Reference callout is a view-specific element referencing another view.
It can have its own crop region shape which doesn't affect the referenced view.
See Also