RebarSpliceUtilsUnifyRebarsIntoOne Method |
This method will unify the rebars by removing the splice between them. A new rebar will be created because of this operation.
The curves of the resulted rebar will be the curves of the first rebar continued by the curves of the second rebar.
The resulted rebar will take data from the first rebar. (e.g.. layout, moved/removed bars, etc.).
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId UnifyRebarsIntoOne(
Document document,
ElementId firstRebarId,
ElementId secondRebarId
)
Public Shared Function UnifyRebarsIntoOne (
document As Document,
firstRebarId As ElementId,
secondRebarId As ElementId
) As ElementId
public:
static ElementId^ UnifyRebarsIntoOne(
Document^ document,
ElementId^ firstRebarId,
ElementId^ secondRebarId
)
static member UnifyRebarsIntoOne :
document : Document *
firstRebarId : ElementId *
secondRebarId : ElementId -> ElementId
Parameters
- document Document
-
The document.
- firstRebarId ElementId
-
First Rebar id.
- secondRebarId ElementId
-
Second Rebar id.
Return Value
ElementId
Returns the id of the new rebar. In case that unify operation fails, it will return invalidElementId
Exceptions
See Also