BRepBuilderPersistentIdsIsBRepBuilderGeometryIdFaceOrEdge Method |
Validates the input BRepBuilderGeometryId that will be used to create a correspondence.
In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsBRepBuilderGeometryIdFaceOrEdge(
BRepBuilderGeometryId brepBuilderGeometryId
)
Public Function IsBRepBuilderGeometryIdFaceOrEdge (
brepBuilderGeometryId As BRepBuilderGeometryId
) As Boolean
public:
bool IsBRepBuilderGeometryIdFaceOrEdge(
BRepBuilderGeometryId^ brepBuilderGeometryId
)
member IsBRepBuilderGeometryIdFaceOrEdge :
brepBuilderGeometryId : BRepBuilderGeometryId -> bool
Parameters
- brepBuilderGeometryId BRepBuilderGeometryId
-
The BRepBuilderGeometryId to be used in a new correspondence.
Return Value
Boolean
True if the input BRepBuilderGeometryId represents the ID of either a Face or an Edge, false otherwise.
Exceptions
Remarks
This method returns false also in the case when the associated BRepBuilder is not valid.
Call
IsAssociatedBRepBuilderValid to check the associated BRepBuilder.
See Also