StairsEditScopeStart(ElementId) Method |
Starts an stairs edit mode for an existing Stairs element
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId Start(
ElementId stairsId
)
Public Function Start (
stairsId As ElementId
) As ElementId
public:
ElementId^ Start(
ElementId^ stairsId
)
member Start :
stairsId : ElementId -> ElementId
Parameters
- stairsId ElementId
-
The stairs element to be edited.
Return Value
ElementId
ElementId of the editing stairs. It should be the same as the input stairsId
ExceptionsException | Condition |
---|
ArgumentException |
It is not a Stair's id.
-or-
Stairs is not permitted to edit at this moment for the following reason:
The Stairs is in an ElementGroup and it is not in Edit Group Mode.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
This StairsEditScope is not permitted to start at this moment for one of the following possible reasons:
The document is in read-only state, or the document is currently modifiable,
or there already is another edit mode active in the document.
|
Remarks
User will need to start a transaction to actually make changes to the stairs element.
StairsEditScope can only be started when there is no transaction active
Thus it does not work for commands running in automatic transaction mode.
See Also